Installing Ringo for
Arduino

Installation

To start programming your own things on Ringo phone you're going to need a
software called CircuitBlocks, which is our program developed specifically for
Ringo phone. Alternatively, you can download Arduino IDE, which is a program
you are already familiar with if you're into IoT.

If you already have it installed on your computer, you can skip this step.

Go to the address: https:/[/www.arduino.cc/en/Main/Software

<« C @ https//www.arduino.cc/en/Main/software *

HOME STORE SOFTWARE EDU RESOURCES COMMUNITY HELP Q @ sonan

Download the Arduino IDE

'Windows Installer, for Windows XP and up
Windows ZIP file for non admin install

ARDUINO 1.8.9

The open-source Arduino Software (IDE) makes it easy to
write code and upload it to the board. It runs on
Windows, Mac OS X, and Linux. The environment is
written in Java and based on Processing and other open-
source software.

This software can be used with any Arduino board

Refer to the Getting Started page for Installation
instructions

©.O)

Windows app Requires Win 810r 10
Get 52

Mac OS X10.8 Mountain Lion or newer

Linux 32 bits
Linux 64 bits
Linux ARM 32 bits

Linux ARM 64 bits

Release Notes
Source Code
Checksums (shaS12)

Download the installation file according to the OS you own. If you have Windows
8.1 or later, you can also download Arduino IDE over Microsoft Store. That version
of the software will be considered to be a completely different program than the
regular version by your system so keep in mind that your libraries will not be in
sync. Other than that, these two versions work the same.

Now when you have installed Arduino we can go to the next step.

Installing Ringo Add-On in Arduino
IDE

These instructions work on every OS since Arduino automatically downloads
tools depending on detected system.

So just follow these steps and you will be fine!

1. Open Arduino IDE

NOTE: If this is your first time meeting Arduino IDE - get familiar, you're going to
use it alot.


https://www.arduino.cc/en/Main/Software
https://www.arduino.cc/en/Main/Software
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}::ici setup() { A

// put your setup code here, to run once:

void loop() {

// put your main code here, to run repeatedly:

Arduino/Genuino Uno on COM5

2. Go to File -> Preferences

file]edit Sketch Tools Help

New Ctrl+N

Open... Ctrl+O

Open Recent >

Sketchbook > "
Examples here, to run once:

Close Ctrl+W

Save Ctrl+S

Save As... Ctrl+Shift+S

Page Setup  Ctrl+Shift+P  |ere, to run repeatedly:
Print Ctrl+P

I Preferences CtrI+Comma|

Quit Ctrl+Q
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3. Enter the following address in the
Additional board Manager URLs :

https://raw.githubusercontent.com/CircuitMess/MAKERphone/boardArduino
[package_CircuitMess_Ringo_index.json
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void setug Sketchbook location:

// put y |C:\Users\medve\OneDrive\Documents\Arduino Browse
) Editor language: System Default v | (requires restart of Arduino)
Editor font size: 12
void 1ooP( Interface scale: Automatic | 100 5 % (requires restart of Arduino)
/7 put Theme: Default theme | (requires restart of Arduino)
} Show verbose output during: [_] compilation [_] upload
Compiler warnings: None v

[] pisplay line numbers

[] enable Code Folding

Verify code after upload

[] use external editor

Aggressively cache compiled core

Check for updates on startup

Update sketch files to new extension on save (.pde -> .ino)

Save when verifying or uploading

IAdditionaI Boards Manager URLs: || Q

More preferences can be edited directly in the file 3
P : ' Enter a comma separated list of URLs
C:\Users\medve\AppData\Local\Arduino15\preferences.ox

(edit only when Arduino is not running)

Cancel
AraamoreenamoJno on COMS

Click OK.

NOTE: You can also click the little window button by the bar and enter it there,
then click OK.
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void setug Sketchbook location:

// put y C:\Users\medve\OneDrive\Documents\Arduino Browse
) Editor language: System Default » | (requires restart of Arduino)
Editor font size: 12
void 1oop( terface scale: [“] Automatic | 100 3 % (requires restart of Arduino)
// put ¥ .
} Show verbose
: Enter additional URLs, one for each row
Compiler warn
https://zaw.gi com/Circui MAKERp ino/package_Circui _Ringo_index.json
[] pisplay line
[J enable Coc
jeriyiccey Click for a list of unofficial boards support URLs
Use extern
O Cancel
Aggressive

Check for updates on startup

Update sketch files to new extension on save (.pde -> .ino)

Save when verifying or uploading
Additional Boards Manager URLs:

More preferences can be edited directly in the file

C:\Users\medve\AppData\Local\Arduino15\preferences.txt

(edit only when Arduino is not running)
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4. Go to Tools -> Board -> Boards Manager...
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Help | Boards Manager... |

Auto Format Ctrl+T A
Archive Sketch Arduino AVR Boards
sketch_aug05 Fix Encoding & Reload Arduino Yun :
void setup() Ma?age Li?raries... Ctrl+Shift+I ® Arduino/Genuino Uno A
// put you Serial Monitor Ctrl+Shift+M Arduino Duemilanove or Diecimila
Serial Plotter Ctrl+Shift+L Arduino Nano
} . .
WiFi101 / WiFiNINA Firmware Updater GREZE ST LD T BT 2250
Arduino Mega ADK
Board: "Arduino/Genuino Uno" |> Arduino Leonardo
Port Arduino Leonardo ETH
} Get Board Info Arduino/Genuino Micro
Programmer N Ardu?no Esﬂora
Burn Bootloader M2 L
Arduino Ethernet
Arduino Fio
Arduino BT

LilyPad Arduino USB
LilyPad Arduino
Arduino Pro or Pro Mini
Arduino NG or older
Arduino Robot Control
Arduino Robot Motor
Arduino Gemma

Adafruit Circuit Playground
Arduino Yan Mini
Arduino Industrial 101

Linino One enuino Uno on COMS

5. Type Ringo' into the bar on top of the pop-
up window

e Edit Sketch Tools Help

Type All v IRinga I

Ringo by CircuitMess

Boards included in this package:
Ringo by CircuitMess.

More info

I Install I

Close

Arduino/Genuino Uno on COM5

There will be one result found called ‘Ringo by CircuitMess".
Click on the 'Install’ button.

NOTE: Main board package and a few tools will now download and install on your
system.

It all takes up about 200 MB so the time of download will depend on your internet
connection.



File Edit Sketch Tools Help

Type |All Ringo
Ringo by CircuitMess
Boards included in this package:
Ringo by CircuitMess.
More info
Installing...
Downloading boards definitions. Downloaded 2,179kb of 31,255kb. E Cancel

Arduino/Genuino Uno on COM5

6. When it's all finished it will write out
INSTALLED next to the version mark

File Edit Sketch Tools Help

<! [Ringo

Ringo by CircuitMess version 1.0.0 INSTALLED
Boards included in this package:

Ringo by CircuitMess.

More info

Close
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Click on the ‘Close’ button and move on.

NOTE: The board file will be updated from time to time so make sure to check the
version from time to time.

When there is an option ‘Update’, please click it in order to stay in touch with the
latest firmware.

Creating with Ringo and Arduino




NOTE

Whenever you upload a program it will effectively “erase’ the whole Ringo

V firmware from the phone. If you want to return it, follow step 13! If you don't
want to do any work on your phone right now, you can skip these next few
steps.

7. Select the installed board
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Auto Format Ctrl+T
Archive Sketch
sketch_aug05 Fix Encoding & Reload
void setup() Manage Libraries... Ctrl+Shift+]
// put you Serial Monitor Ctrl+Shift+M
Serial Plotter Ctrl+Shift+L

WiFi101 / WiFiININA Firmware Updater

0 || Board: "Arduino/Genuino Uno” P Boards Manager...
o Port Arduino AVR Boards
Get Board Info Arduino Yin

Arduino/Genuino Uno
Programmer 2

Burn Bootloader Arduino Duemilanove or Diecimila
Arduino Nano

Arduino/Genuino Mega or Mega 2560
Arduino Mega ADK

Arduino Leonardo

Arduino Leonardo ETH
Arduino/Genuino Micro

Arduino Esplora

Arduino Mini v
Arduino Ethernet
Arduino Fio

Arduino BT

LilyPad Arduino USB
LilyPad Arduino
Arduino Pro or Pro Mini
Arduino NG or older
Arduino Robot Control
Arduino Robot Motor
Arduino Gemma
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Adafruit Circuit Playground
Arduino Ydn Mini
Arduino Industrial 101
Linino One
Arduino Uno WiFi
ESP32 Arduino

I® Ringo by CircuitMess

Again go to Tools -> Board and in the dropdown menu under category ‘ESP32
Arduino’ find ‘Ringo by CircuitMess'.

It should be somewhere at the bottom. Select the board.

8. If you haven't already, connect your Ringo
phone to the PC via micro-USB to USB cable



File Edit Sketch[Tools] Help

Auto Format Ctrl+T
Archive Sketch

Fix Encoding & Reload

Manage Libraries... Ctrl+Shift+l A
Serial Monitor Ctrl+Shift+M
Serial Plotter Ctrl+Shift+L

WIFi101 / WiFiNINA Firmware Updater

Board: "Ringo by CircuitMess” >
Upload Speed: "921600" >
} Flash Frequency: "80MHz" >
Partition Scheme: "Minimal SPIFFS (Large APPS with OTA)" >
Core Debug L_evel: “"None" >
I Port: "COM5" I> Serial ports
Get Board Info I\/ COM5 I
Programmer >

Burn Bootloader

Ringo by CircuitMess on COM5

It will connect to one of the COM ports.

Go to Tools' and under ‘Board’ section select ‘Port’ and find the port on which
Ringo is connected.

NOTE: If 'Port’ is greyed out it means the phone is not correctly connected.

Change the USB port and/or check your cable.

9. Write your first program

In the void setup() section write the following line:

Serial.begin(115200);

Under the void loop() section write something like this:

Serial.print("My first Arduino program for CircuitMess Ringo! ");

Now click on the little ‘'Upload’ arrow in the upper left corner.
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oo D g g Upload
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void setup() { A
Serial.begin(115200);
}
void loop()
Serial.print ("My first Arduino program for CircuitMess Ringo! ");
}
v

Ringo by CircuitMess on COM5

10. After a few moments, the text should say
Done uploading

Now the only thing left to do is to check if everything is working properly.

Click the magnifier icon in the upper right corner of the screen.
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void setup() { A
Serial.begin(115200);

}

void loop()

Serial.print ("My first Arduino program for CircuitMess Ringo! ");

Ringo by CircuitMess on COM5

11. On a newly opened window, from a drop-
down menu, select 115200 baud

That is the speed that the software writes in the Serial monitor.

If the text says the line that you wrote in the print function, then everything works!
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Send

CircuitMess Ringo! My first Arduino program for CircuitMess Ringo! My first Arduino program for 7

< >

[ Autoscroll [_] Show timestamp Newline | 1115200 baud v Clear output
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Library and restoring firmware

12. Installing Ringo library

There is also a Ringo library in Arduino Library Manager that allows you to use all
the important functions and libraries from the Ringo firmware when writing your
own programs. Printing out things on the screen and pressing buttons won't be
possible without this one.

Go to Sketch-> Include Library -> Manage Libraries.... Enter the keyword ‘Ringo’
in the search bar and click the ‘Install’ button to download and install the library.

Type All v Topic All v | Ringo

Ringo by CircuitMess Library by CircuitMess Version 1.0.0 INSTALLED A
Ringo is an educational DIY mobile phone designed to bring electronics and programming to the crowd in a fun and interesting way. See

more on https://www kickstarter.com/projects/albertgajsak/makerphone-an-educational-diy-mobile-phone

More info

Close

13. Re-uploading the 'Default Ringo software’

Whenever you want to re-upload ‘Default Ringo Software’ you have to go
to Tools -> Programmer and select

‘Ringo Firmware'.
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Archive Sketch
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#include Manage Libraries... Ctrl+Shift+ A
Serial Monitor Ctrl+Shift+M
MAKERphon Serial Plotter Ctrl+Shift+L
WiFi101 / WiFiNINA Firmware Updater
Board: "Ringo by CircuitMess" >
Upload Speed: "921600" >
Flash Frequency: "80MHz" >
Partition Scheme: "Minimal SPIFFS (Large APPS with OTA)" >
Core Debug Level: "None" >
Port: "COM10 (Ringo by CircuitMess)" >
Get Board Info
Programmer: "Ringo Firmware" 3 Onboard Atmel mEDBG (UNO WiFi Rev2)
mp. Burn Bootloader AVR ISP
mp.c y.fillrRect (20, 20, 20, 20, TFT_GREEN); AVRISP mkll
USBtinylSP
} ArduinolSP
ArduinolSP.org
USBasp
Parallel Programmer
Arduino as ISP
Arduino Gemma
BusPirate as ISP
Atmel STK500 development board
Atmel JTAGICE3 (ISP mode) ]
Atmel JTAGICE3 (JTAG mode)
Atmel-ICE (AVR)
" . | Ringo Firmware
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Now go to Tools -> Burn Bootloader and you will have the latest default firmware
on your Ringo as soon as

the upload is finished.
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Auto Format Ctrl+T
Archive Sketch
sketch_oct07hy Fix Encoding & Reload
#include Manage Libraries... Ctrl+Shift+| N
Serial Monitor Ctrl+Shift+M
MAKERphon Serial Plotter Ctrl+Shift+L

WiFi101 / WiFiNINA Firmware Updater

Board: "Ringo by CircuitMess" >
Upload Speed: "921600" >
Flash Frequency: "80MHz" >
Partition Scheme: "Minimal SPIFFS (Large APPS with OTA)" >
Core Debug Level: “None" >
Port: "COM10 (Ringo by CircuitMess)" >

Get Board Info

Programmer: "Ringo Firmware" >

Burn Bootloader
y.£illRect (20, 20, 20, 20, TFT_GREEN);
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Congrats! You have successfully set up Ringo phone.

Now let’s get to business and start creating some cool apps and games!



